import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^_\\n]+_).*\\b([^\\s_]*_.*)(?=\\.)";
final String string = "111111_SMITH, JIM_END TLD 6-01-20 THR LEWISHS.pdf\n"
+ "222222_JONES, MIKE_G URS TO 7.25 2-28-19 SA COOPSHS.pdf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}