re = /^([^_\n]+_).*\b([^\s_]*_.*)(?=\.)/m
str = '111111_SMITH, JIM_END TLD 6-01-20 THR LEWISHS.pdf
222222_JONES, MIKE_G URS TO 7.25 2-28-19 SA COOPSHS.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end