package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[(\d+)\]`)
var str = `[some_strings] id:[1227194]
[some_strings] id:[1227195]
[some_strings] id:[1227196]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}