$re = '/\[(\d+)\]/m';
$str = '[some_strings] id:[1227194]
[some_strings] id:[1227195]
[some_strings] id:[1227196]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);