re = /^(?:(?:\d+(?:-\d+)?),?)+$/m
str = '1
1-2
1,23,1-4,5,23,123
1,2,3,4,5,6-10
1,123-123,4,1,66,123
1-2,2-3,3-4,4-5,6-7,8,9,10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end