const regex = /^(?=(\D*\d){2})(?=([^a-zA-Z]*[a-zA-Z]){2}).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(\\D*\\d){2})(?=([^a-zA-Z]*[a-zA-Z]){2}).*$', 'gm')
const str = `abc123efg890`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}