$re = '/^(?=(\D*\d){2})(?=([^a-zA-Z]*[a-zA-Z]){2}).*$/m';
$str = 'abc123efg890';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);