$re = '/(?<!Fixture)\.php$/m';
$str = 'FooBarFixture.php
Fixture.php
File.php
FixtureBox.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);