re = /(?<!Fixture)\.php$/m
str = 'FooBarFixture.php
Fixture.php
File.php
FixtureBox.php'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end