package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d*::[a-zA-Z]+[^\(]*\(\d{4}\)::(?<disease>(?:HIV|Cancer|flu|Arthritis|OCD)(?:\|(?:HIV|Cancer|flu|Arthritis|OCD))*)$`)
var str = `24::Robin (1980)::HIV|Cancer|Cancer|HIV
24::Robin (1980)::HIV|Cancer|Cancer|HIV|test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}