re = /\(([0-9\-\s,.]+)\)/m
str = '(-6.2811957386588855, 106.70141951079609),(-6.281142416506361, 106.70432702536823),(-6.2781776962328815, 106.70438066954853),(-6.2781776962328815, 106.70136586661579)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end