re = /(?:^|\/)((?:19|20)[0-9]{2})\/((?:0?[1-9]|1[0-2])(?:-(?:0?[1-9]|1[0-2]))?)(?:\/|$)/m
str = '/www.site.com/path1/resort/2021/02/sitename
/www.site.com/path1/2021/02
/www.site.com/path1/2020/11-12
/www.site.com/path1/2020/07-08
/www.site.com/path1/resort/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end