using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div\sid=\""olpProductDetails[\s\S]*?<h1[\s\S]*?<div[\s\S]*?<span[\s\S]*?>[\s\S]*?\s*<\/span>\s*<\/div>\s*[\s\S]*?[\s]+<\/h1>[\s\S]*?<div\sid=\""olpProductByline\""[\s\S]*?>[\s\S]*?by\s([\s\S]*?)[\s]+<\/div>";
string input = @"<div id=""olpProductDetails"" class=""a-fixed-left-grid-col a-col-right"" style=""padding-left:0%;float:left;"">
<h1 class=""a-size-large a-spacing-none"" role=""main""> <div class=""a-section a-spacing-none olpSubHeadingSection""> <span class=""a-size-base a-color-secondary""> </span> </div> Keds Women's Chillax Washed Laceless Slip-On Sneaker, Taupe, 8 M US
</h1>
<div id=""olpProductByline"" class=""a-section a-spacing-mini"">
by Keds
</div>
<div class=""a-section a-spacing-small"">
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}