const regex = /<div\sid=\"olpProductDetails[\s\S]*?<h1[\s\S]*?<div[\s\S]*?<span[\s\S]*?>[\s\S]*?\s*<\/span>\s*<\/div>\s*[\s\S]*?[\s]+<\/h1>[\s\S]*?<div\sid=\"olpProductByline\"[\s\S]*?>[\s\S]*?by\s([\s\S]*?)[\s]+<\/div>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div\\sid=\\"olpProductDetails[\\s\\S]*?<h1[\\s\\S]*?<div[\\s\\S]*?<span[\\s\\S]*?>[\\s\\S]*?\\s*<\\\/span>\\s*<\\\/div>\\s*[\\s\\S]*?[\\s]+<\\\/h1>[\\s\\S]*?<div\\sid=\\"olpProductByline\\"[\\s\\S]*?>[\\s\\S]*?by\\s([\\s\\S]*?)[\\s]+<\\\/div>', 'gm')
const str = `<div id="olpProductDetails" class="a-fixed-left-grid-col a-col-right" style="padding-left:0%;float:left;">
<h1 class="a-size-large a-spacing-none" role="main"> <div class="a-section a-spacing-none olpSubHeadingSection"> <span class="a-size-base a-color-secondary"> </span> </div> Keds Women's Chillax Washed Laceless Slip-On Sneaker, Taupe, 8 M US
</h1>
<div id="olpProductByline" class="a-section a-spacing-mini">
by Keds
</div>
<div class="a-section a-spacing-small">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}