$re = '`\bEtc/\S*|(UTC|GMT)?([+-])(\d{1,2})([:.])?(\d{1,2})?`';
$str = 'GMT+01:00
UTC+01:00
UTC+01
+01:00
Etc/GMT+01:00
Etc/UTC+01:00
Etc/UTC+01';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);