#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^APPLE(?!.*TEA)(?!.*WINE1C).*"
Local $sString = "APPLEJUCE1A" & @CRLF & _
"APPLETREE2B" & @CRLF & _
"APPLECAKE3C" & @CRLF & _
"APPLETEA1B" & @CRLF & _
"APPLEWINE3B" & @CRLF & _
"APPLEWINE1C"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")