re = /^APPLE(?!.*TEA)(?!.*WINE1C).*/m
str = 'APPLEJUCE1A
APPLETREE2B
APPLECAKE3C
APPLETEA1B
APPLEWINE3B
APPLEWINE1C'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end