$re = '~^ristoranti/(?!location/)([^/]*)/([^/]*)/(.*)~m';
$str = 'ristoranti/location/latvia/riga/other-tag
ristoranti/latvia/riga/other-tag';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);