re = /^ristoranti\/(?!location\/)([^\/]*)\/([^\/]*)\/(.*)/m
str = 'ristoranti/location/latvia/riga/other-tag
ristoranti/latvia/riga/other-tag'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end