$re = '~\bINSERT\s+INTO\s+\S+\s*\(([^)]+)\)\s*VALUES\s*\(([^)]+)\)~m';
$str = 'INSERT INTO MyTable (column1, column2, column3, column4, column5 ) VALUES (1, \'Hi\', \'A,B\', \'\', null)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);