re = /\bINSERT\s+INTO\s+\S+\s*\(([^)]+)\)\s*VALUES\s*\(([^)]+)\)/m
str = 'INSERT INTO MyTable (column1, column2, column3, column4, column5 ) VALUES (1, \'Hi\', \'A,B\', \'\', null)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end