package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)КАТЕГОРИЯ:\s+(?P<Category>.*)ИСТЕЦ:\s+(?P<Plaintiff>.*)ОТВЕТЧИК:\s+(?P<Defendant>.*)`)
var str = `КАТЕГОРИЯ: ТекстИСТЕЦ: Текст.ОТВЕТЧИК: Текст`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}