re = /КАТЕГОРИЯ:\s+(?P<Category>.*)ИСТЕЦ:\s+(?P<Plaintiff>.*)ОТВЕТЧИК:\s+(?P<Defendant>.*)/m
str = 'КАТЕГОРИЯ: ТекстИСТЕЦ: Текст.ОТВЕТЧИК: Текст'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end