using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((object|inherited) \w+:[ ](TMgDBEdit).*?)((Color = clInactiveCaptionText\n)|(\n\s+end))";
string substitution = @"\1ParentFont = True\n";
string input = @" object Ed_PRO_ST_DESCRICAO: TMgDBEdit
Left = 132
Top = 81
Width = 675
Height = 21
AutoSize = False
Color = clInactiveCaptionText
DataField = 'PRO_ST_DESCRICAO'
DataSource = Dm_AdmInt.Ds_Produtos_
TabOrder = 4
OnChange = Ed_PRO_ST_DESCRICAOChange
OnExit = Ed_PRO_ST_DESCRICAOExit
OnKeyPress = Ed_PRO_ST_DESCRICAOKeyPress
Password = False
end
object Ed_PRO_ST_NARRATIVA1: TMgDBMemo
Left = 132
Top = 157
Width = 675
Height = 78
DataField = 'PRO_ST_NARRATIVA'
DataSource = Dm_AdmInt.Ds_Produtos_
MaxLength = 500
ScrollBars = ssVertical
TabOrder = 7
end
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}