import re
regex = re.compile(r"((object|inherited) \w+:[ ](TMgDBEdit).*?)((Color = clInactiveCaptionText\n)|(\n\s+end))", flags=re.MULTILINE | re.IGNORECASE | re.DOTALL)
test_str = (" object Ed_PRO_ST_DESCRICAO: TMgDBEdit\n"
" Left = 132\n"
" Top = 81\n"
" Width = 675\n"
" Height = 21\n"
" AutoSize = False\n"
" Color = clInactiveCaptionText\n"
" DataField = 'PRO_ST_DESCRICAO'\n"
" DataSource = Dm_AdmInt.Ds_Produtos_\n"
" TabOrder = 4\n"
" OnChange = Ed_PRO_ST_DESCRICAOChange\n"
" OnExit = Ed_PRO_ST_DESCRICAOExit\n"
" OnKeyPress = Ed_PRO_ST_DESCRICAOKeyPress\n"
" Password = False\n"
" end\n"
" object Ed_PRO_ST_NARRATIVA1: TMgDBMemo\n"
" Left = 132\n"
" Top = 157\n"
" Width = 675\n"
" Height = 78\n"
" DataField = 'PRO_ST_NARRATIVA'\n"
" DataSource = Dm_AdmInt.Ds_Produtos_\n"
" MaxLength = 500\n"
" ScrollBars = ssVertical\n"
" TabOrder = 7\n"
" end\n")
subst = "\\1ParentFont = True\\n"
result = regex.sub(subst, test_str)
if result:
print(result)