$re = '`^.*\]|(\w+\.)`m';
$str = 'some text [asred.] ost. |Monday - Ribben (ult.) lot. ac, sino. other maybe long text; collan. test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);