re = /^.*\]|(\w+\.)/m
str = 'some text [asred.] ost. |Monday - Ribben (ult.) lot. ac, sino. other maybe long text; collan. test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end