import re
regex = re.compile(r".*(https)*\/(.*)\.(.*\?|.*$)(.*$)", flags=re.MULTILINE)
test_str = "https://dso.nr.ncia/qa/ivva/_layouts/15/listform.aspx"
subst = "$2.$3 "
result = regex.sub(subst, test_str)
if result:
print(result)