use strict;
my $str = '/advanced_search_result.php
/shopping_cart.php
/create_account.php
/index.php
/wetsuits-cx-1.html
/not_found.php
/womens-wetsuits-cx-15.html
/checkout_confirmation.php
/checkout_payment.php
/mens-wetsuits-cx-14.html
/womens-c-47_65.html
/sv-se/index.php
/de-ch/2020-helly-hansen-50n-rider-vest-buoyancy-aid-33820-red-p-11170.html
/sale/index.php
/fi-fi/index.php
/en-dk/index.php
/nl-be/index.php
/no-no/index.php
/es-us/index.php
watersportsoutlet.com/es-us/index.php
www.watersportsoutlet.com/es-us/index.php
watersportsoutlet.com/no-no/index.php
www.watersportsoutlet.com/no-no/index.php
/ext/modules/payment/paypal/checkout.php';
my $regex = qr/(\/[\D]{2}-((?!us).){2}\/)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}