import re
regex = re.compile(r"(\/[\D]{2}-((?!us).){2}\/)", flags=re.MULTILINE)
test_str = ("/advanced_search_result.php\n"
"/shopping_cart.php\n"
"/create_account.php\n"
"/index.php\n"
"/wetsuits-cx-1.html\n"
"/not_found.php\n"
"/womens-wetsuits-cx-15.html\n"
"/checkout_confirmation.php\n"
"/checkout_payment.php\n"
"/mens-wetsuits-cx-14.html\n"
"/womens-c-47_65.html\n"
"/sv-se/index.php\n"
"/de-ch/2020-helly-hansen-50n-rider-vest-buoyancy-aid-33820-red-p-11170.html\n"
"/sale/index.php\n"
"/fi-fi/index.php\n"
"/en-dk/index.php\n"
"/nl-be/index.php\n"
"/no-no/index.php\n"
"/es-us/index.php\n"
"watersportsoutlet.com/es-us/index.php\n"
"www.watersportsoutlet.com/es-us/index.php\n"
"watersportsoutlet.com/no-no/index.php\n"
"www.watersportsoutlet.com/no-no/index.php\n"
"/ext/modules/payment/paypal/checkout.php")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")