package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d*\.?\d{0,3}$`)
var str = `22.222`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}