$re = '/^\d*\.?\d{0,3}$/m';
$str = '22.222';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);