#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^|(?<=[\s,;:.!?])+)[A-Za-z]+($|(?=[\s,;:.!?]+))"
Local $sString = "startword first second,third;fourth:not#word not1word: fifth,, ; sixth; preendword.endword" & @CRLF & _
"startword first second,third;fourth:not#word not1word: fifth,, ; sixth; preendword!endword" & @CRLF & _
"startword first second,third;fourth:not#word not1word: fifth,, ; sixth; preendword?endword"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")