using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|(?<=[\s,;:.!?])+)[A-Za-z]+($|(?=[\s,;:.!?]+))";
string input = @"startword first second,third;fourth:not#word not1word: fifth,, ; sixth; preendword.endword
startword first second,third;fourth:not#word not1word: fifth,, ; sixth; preendword!endword
startword first second,third;fourth:not#word not1word: fifth,, ; sixth; preendword?endword";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}