import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\D{5}\\d{4}\\D\\b";
final String string = "pan number : ASDFG4356P\n"
+ "pan number : WERTSDFG4356P\n"
+ "pan number : DFG4356P\n"
+ "pan number : ASDFG4356PRTE\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}