// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b\D{5}\d{4}\D\b").unwrap();
let string = "pan number : ASDFG4356P
pan number : WERTSDFG4356P
pan number : DFG4356P
pan number : ASDFG4356PRTE
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}