import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*SA.*CV";
final String string = "MEGA ZAPATO SA DE CV\n"
+ "ALBERTO ESTEBAN MEZA SOL\n"
+ "NET & SERVICES TRANTOR SA DE CV\n"
+ "LAURA YADIRA CEJA PEREZ\n"
+ "CUAUHTEMOC MERCADO BELTRAN\n"
+ "OPERADORA BRASILEÑA SA DE CV\n"
+ "JAIME ALDAIR ROBLES PEREZ\n"
+ "TIENDAS HR SA DE CV\n"
+ "SMARTIUM ACADEMIC GROUP SA DE CV\n"
+ "LA ESPERANZA Y MAS SPR DE RL DE CV\n"
+ "MANUFACTURAS PROINSE S.A DE CV\n"
+ "MAURICIO SANCHEZ GOMEZ\n"
+ "LUIS GERARDO HERNANDEZ ESPINOSA\n"
+ "IMPORTADORA SAMEX SA DE CV\n"
+ "PETROTEKNO SA DE CV\n"
+ "CONDOTEL B NAYAR SA DE CV\n"
+ "GTRES GRUPO EMPRESARIAL SA DE CV\n"
+ "GRUPO INDUSTRIAL RIO RICO S DE RL DE CV\n"
+ "GERARDO GONZALEZ TORRES\n"
+ "ALEJANDRA PASILLAS PERPULY\n"
+ "GRUPO LARA VILLALOBOS SA DE CV\n"
+ "CONSTRUCTORA RAFEGA SA DE CV\n"
+ "DIEGO ARTURO HERNANDEZ GARCIA\n"
+ "RECICLADOS DRAGON SA DE CV\n"
+ "AGRO-IPSA SA DE CV\n"
+ "LOS CUES INMOBILIARIA SA DE CV\n"
+ "ILERICSA SA DE CV\n"
+ "JAVIER ESTRADA SALGADO\n"
+ "JESUS HUMBERTO HERNANDEZ SEGUNDO\n"
+ "TRANSPORTE DE PERSONAL ESPECIALIZADO SA DE CV\n"
+ "IF VERTICAL 2 SAPI DE CV\n"
+ "CIMEIRA S DE RL DE CV\n"
+ "MANAVIL COMERCIALIZADORA SA DE CV\n"
+ "BS DE MEXICO SA DE CV\n"
+ "ARRENDADORA AUTOMOTRIZ HERMES SA DE CV\n"
+ "GD TRAILERS SA DE CV\n"
+ "AVACOR SA DE CV\n"
+ "EFICIENCIA EN SISTEMAS DE ENERGIA RENOVABLE DEL CENTRO SA DE CV\n"
+ "KP EXTRUSION DE MEXICO SA DE CV\n"
+ "SISTEMAS DE CARGA ESPECIALIZADA SA DE CV\n"
+ "ARRENDADORA AUTOMOTRIZ HERMES SA DE CV\n"
+ "SUFERRE DEL BAJIO SA DE CV\n"
+ "SETRIC BEST S DE RL DE CV\n"
+ "AMD MAQUINARIA SA DE CV\n"
+ "MODULAR VANITY TOPS SA DE CV\n"
+ "MII MAVI SA DE CV\n"
+ "CONSTRUSERVICIOS ESL SA DE CV\n"
+ "ANDALUCIA CLINICA DE ESPECIALIDADES SA DE CV\n"
+ "SERVICIOS ESPECIALIZADOS DE INVESTIGACION Y CUSTODIA SA DE CV\n"
+ "RYSE MEDICA SA DE CV\n"
+ "AGROTILENO DE MEXICO SA DE CV\n"
+ "MEDICA SANTA CARMEN SAPI DE CV\n"
+ "ABSTEN DIAGNOSTIK SA DE CV\n"
+ "TLP SERVICIOS SA DE CV\n"
+ "GRUPO ABARMAR SA DE CV\n"
+ "BAJA SUR CONCRETOS SA DE CV\n"
+ "TLP SERVICIOS SA DE CV\n"
+ "GRUPO GARDOMI SA DE CV\n"
+ "PRESTADORES DE SERVICIOS EXTERNOS SA DE CV\n"
+ "FRESH SEASON SA DE CV\n"
+ "SEGURIDAD PRIVADA INTEGRAL MANAVIL SA DE CV\n"
+ "DISEÑOS DE MODA DMC SA DE CV\n"
+ "UNION DE CRIADORES LAS PRADERAS SPR DE RL\n"
+ "INDUSTRIAS SANDOVAL SA DE CV\n"
+ "RLX INVESCO II SA DE CV\n"
+ "HI TEC CONSTRUCCION SA DE CV\n"
+ "VARSAL DISTRIBUCIONES SA DE CV\n"
+ "GUMA DE OCCIDENTE SA DE CV\n"
+ "TYDAN TUBOS Y DERIVADOS DE ACERO DEL NORESTE SA DE CV\n"
+ "NUEVO WKS DOOR SYSTEMS SA DE CV\n"
+ "GC PISOS LASER SA DE CV\n"
+ "BERCALE SERVICES SA DE CV\n"
+ "EURO ALEMANA CAMIONES SA DE CV\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}