$re = '/^[a-zA-Z][a-zA-Z \'-.‘’]+$/m';
$str = 'Hello -ahmad
-Hello
hello ahmad-
hello - ahmasd fkhakdsjhf kadflka dad.\'ad123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);