re = /^[a-zA-Z][a-zA-Z '-.‘’]+$/m
str = 'Hello -ahmad
-Hello
hello ahmad-
hello - ahmasd fkhakdsjhf kadflka dad.\'ad123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end