import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Classics-(?P<Title>.*?)(?: +[[(](?P<Author>[^])]*)[])])?(?: +[[(][^])]*[])])*$";
final String string = "Classics-The Wealth of Nations\n"
+ "Classics-The Jungle Book [Rudyard Kipling] (illustrated)\n"
+ "Classics-Ulysses (James Joyce)\n"
+ "Classics-Sense and Sensibility\n"
+ "Classics-Don Quixote (Miguel de Cervantes)\n\n\n"
+ "Expect:\n"
+ "The Wealth of Nations\n"
+ "The Jungle Book\n"
+ "Ulysses\n"
+ "Sense and Sensibility\n"
+ "Don Quixote";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}