import Foundation
let pattern = #"^Classics-(?P<Title>.*?)(?: +[[(](?P<Author>[^])]*)[])])?(?: +[[(][^])]*[])])*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Classics-The Wealth of Nations
Classics-The Jungle Book [Rudyard Kipling] (illustrated)
Classics-Ulysses (James Joyce)
Classics-Sense and Sensibility
Classics-Don Quixote (Miguel de Cervantes)
Expect:
The Wealth of Nations
The Jungle Book
Ulysses
Sense and Sensibility
Don Quixote
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)