$re = '/(?<=\[)[^][]*(?=\])|(?<!\S)\w+(?!\S)/m';
$str = '[one] [two] [three] 1234567890ABC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);