re = /(?<=\[)[^][]*(?=\])|(?<!\S)\w+(?!\S)/m
str = '[one] [two] [three] 1234567890ABC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end