import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)cc";
final String string = "TVS Star City Plus Dual Tone 110cc 2018\n"
+ "Royal Enfield Classic 350cc 2017\n"
+ "Triumph Daytona 675R 2013\n"
+ "TVS Apache RTR 180cc 2017\n"
+ "Yamaha FZ S V 2.0 150cc-Ltd. Edition 2018\n"
+ "Yamaha FZs 150cc 2015";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}