# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d+)cc"
test_str = ("TVS Star City Plus Dual Tone 110cc 2018\n"
"Royal Enfield Classic 350cc 2017\n"
"Triumph Daytona 675R 2013\n"
"TVS Apache RTR 180cc 2017\n"
"Yamaha FZ S V 2.0 150cc-Ltd. Edition 2018\n"
"Yamaha FZs 150cc 2015")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.