#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\w*)_\d{1}\.\d{1}\.zip"
Local $sString = "IDG_COM_UR_PREV_CLT_0.1.zip" & @CRLF & _
"IDG_COM_UR_PREV_CLT_0.2.zip" & @CRLF & _
"IDG_COM_UR_TEST_0.1.zip" & @CRLF & _
"IDG_COM_UR_TEST_0.2.zip" & @CRLF & _
"IDG_COM_UR_TEST_TEST_TEST_TEST_TEST_0.1.zip" & @CRLF & _
"IDG_COM_UR_TEST_TEST_TEST_TEST_0.2.zip"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)