# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\w*)_\d{1}\.\d{1}\.zip"
test_str = ("IDG_COM_UR_PREV_CLT_0.1.zip\n"
"IDG_COM_UR_PREV_CLT_0.2.zip\n"
"IDG_COM_UR_TEST_0.1.zip\n"
"IDG_COM_UR_TEST_0.2.zip\n"
"IDG_COM_UR_TEST_TEST_TEST_TEST_TEST_0.1.zip\n"
"IDG_COM_UR_TEST_TEST_TEST_TEST_0.2.zip")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.