import re
regex = re.compile(r"^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])[\da-zA-z]{5,8}$", flags=re.MULTILINE)
test_str = ("Amc01\n"
"Ac\n"
"aa0aa\n"
"0aaaa\n"
"aa0aaAadwaw\n"
"ghG789")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")