re = /^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])[\da-zA-z]{5,8}$/m
str = 'Amc01
Ac
aa0aa
0aaaa
aa0aaAadwaw
ghG789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end