re = /[^\s\/]*\/IN\b[^\/]*/
str = 'Alun-alun/NNP Jombang/NNP tepatnya/RB Depan/IN SMP/NNP 2/CDP Jombang/NNP Besok/NNP pagi/NN :/: :/: :/: Minggu/NNP'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end